View Issue Details

IDProjectCategoryView StatusLast Update
0001829GeoSetterUser Interfacepublic2018-01-09 14:23
ReporterajftAssigned ToFriedemann 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
PlatformWindowsOSWindows10OS Version10.0.14393
Product Version3.4.16 beta 
Target VersionFixed in Version3.4.82 beta 
Summary0001829: geosetter warning regarding embedded Google Maps -- unsupported browser
DescriptionThe embedded map in Geosetter (on my Windows10 system) is now displaying:

You are using a browser that is not supported by the Google Maps JavaScript
API. Considering changing your browser. Learn more Dismiss

Note: Geosetter is version 3.4.16 (Build 2119) but that version is not available in the "Product Version" drop-down list above.
Steps To ReproduceOpen geosetter, warning appears as soon as map is displayed
TagsNo tags attached.

Relationships

duplicate of 0001828 resolvedFriedemann Google Maps 

Activities

ceroni

2017-12-05 14:17

reporter   ~0003275

Exactly the same warning here:
"You are using a browser that is not supported by the Google Maps JavaScript API. Considering changing your browser. Learn more Dismiss"

Despite the warning, everything seems to be working fine after clicking “Dismiss”.

Windows 10 Pro 1709 build 16299.64 (64bit)
Microsoft Internet Explorer 11.64.16299.0 (default browser is Opera 49.0.2725.47)
Geosetter 3.4.16 (build 2119)
Exiftool 10.67

alan-g

2017-12-18 20:48

reporter   ~0003282

Same here

Malcolm_Ferguson

2017-12-18 22:31

reporter   ~0003283

I'm running Windows 7 with the IE 11. The link in the error message leads to a page with some hints:
https://developers.google.com/maps/documentation/javascript/error-messages#unsupported-browsers

Malcolm_Ferguson

2017-12-18 22:35

reporter   ~0003284

I guess this is a duplicate (or English version) of: 0001828

rlsmith46

2018-01-06 17:34

reporter   ~0003287

The same error message with the same symptoms occurred recently in Picasa as well.

On the Picasa forum the source of the error was attributed to a Windows 10 update and was solved by a user (Christine) with a registry entry change:

  
Christine Schulze-Dammert said:
I found a solution
regedit:
HKey_Current_User\Software\Microsoft\Internet Explorer\Main\FeatureControl\Feature_Browser_Emulation
Add a DWORD named "picasa3.exe" and set to 2af8.
Then Picasa shows the location of a picture again.
I guess, this was changed during the last upgrade of Windows 10

That solved the problem for Picasa

See the post in the forum at: https://productforums.google.com/d/msg/picasa/mHZcTDkUrMQ/USfnZNlqAwAJ

Perhaps this will be of help in tracking down the error in Geosetter (??)

Friedemann

2018-01-08 16:24

administrator  

geosetter_internet_explorer.reg (358 bytes)

Friedemann

2018-01-08 16:25

administrator   ~0003288

Last edited: 2018-01-09 14:23

View 2 revisions

For the regular release 3.4.16 I attached the needed registry file here, which can be imported by double click.

The new beta version 3.4.82 always adds the registry entry on startup.

Friedemann

2018-01-09 12:03

administrator   ~0003293

Last edited: 2018-01-09 12:03

View 2 revisions

The beta version is available at http://www.geosetter.de/geosetter_beta.exe

Friedemann

2018-01-09 14:23

administrator   ~0003295

Please note: The current beta version mentioned above is wrong, it still seems to be the old version. Will be fixed today... See also 0001836

Issue History

Date Modified Username Field Change
2017-11-27 23:54 ajft New Issue
2017-12-05 14:17 ceroni Note Added: 0003275
2017-12-18 20:48 alan-g Note Added: 0003282
2017-12-18 22:31 Malcolm_Ferguson Note Added: 0003283
2017-12-18 22:35 Malcolm_Ferguson Note Added: 0003284
2018-01-06 17:34 rlsmith46 Note Added: 0003287
2018-01-08 16:21 Friedemann Relationship added duplicate of 0001828
2018-01-08 16:23 Friedemann Status new => resolved
2018-01-08 16:23 Friedemann Fixed in Version => 3.4.82 beta
2018-01-08 16:23 Friedemann Resolution open => fixed
2018-01-08 16:23 Friedemann Assigned To => Friedemann
2018-01-08 16:24 Friedemann File Added: geosetter_internet_explorer.reg
2018-01-08 16:25 Friedemann Note Added: 0003288
2018-01-09 12:03 Friedemann Note Added: 0003293
2018-01-09 12:03 Friedemann Note Edited: 0003293 View Revisions
2018-01-09 14:23 Friedemann Note Added: 0003295
2018-01-09 14:23 Friedemann Note Edited: 0003288 View Revisions